Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

possible vapor lock problem?


 
Post new topic   Reply to topic     Forum Index -> CJ Forum
View previous topic :: View next topic  
Author Message
chappy
Member


Joined: 13 Sep 2005
Location: Indiana

PostPosted: Mon Oct 03, 2005 6:28 am    Post subject: possible vapor lock problem? Reply with quote

I have a 86 cj7 with a 80 model year 360. During hot weather it stumbles violently. I have traced this back to the fuel pressure. I installed a new mechanical pump. It did not fix it. So I installed a 10-14 psi electric pump. Since the weather has been cooler (and I have been running short trips) I have not noticed the problem. Saturday while driving home after idling in a drive through which got the Jeep good and hot it started again. This was after driving 60-65 miles per hour for 5min. That puts the RPM's at about 3100. I put a pressure gauge on it Sunday and when I started it (cold) I had 11psi. I let it idle for 15-20min and I heard the engine die. I went out and restated the hot motor and I was showing 2-3 psi.

I have a new fuel tank/sending unit. I have ran new fuel line forward from about the rear axle getting the line away from the exhaust. My electronic pump is mounted at the bottom of the passenger fender. This maybe to far forward ( I know that electric pumps are better pushers than pullers). If you have any ideas they would be appreciated. Thank you in advance.

Matt
Back to top
View user's profile Send private message
wqrt
Member


Joined: 23 Aug 2005

PostPosted: Thu Oct 06, 2005 4:53 am    Post subject: Reply with quote

I think I'm experiencing the same problem on my `80 CJ-7. When it gets hot it will puke black smoke and act like it is choking itself out then stall. Then it doesn't want to start again. Is this similar to what your experiencing? If so I'll keep checking back to see if anyone has the answer to fix the problem.
Back to top
View user's profile Send private message Send e-mail
chappy
Member


Joined: 13 Sep 2005
Location: Indiana

PostPosted: Thu Oct 06, 2005 6:12 am    Post subject: Reply with quote

My Jeep doesn't smoke. It just looses fuel pressure and dies.

I did move my pump back next to the tank. This did not help. I am going to drop the tank to check for obstructions.

Matt
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> CJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group