Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

'89 Wagoneer starts but will not run with load put on it


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
hondo
Member


Joined: 04 Feb 2005
Location: Idaho

PostPosted: Fri Feb 04, 2005 6:32 pm    Post subject: '89 Wagoneer starts but will not run with load put on it Reply with quote

I have a '89 wagoneer 4.0 EFI, I6, Auto, I would hate to part out but the old girl (345,000 miles on it) got something going on with it I can't narrow down. It starts but will not run after you step on the gas, It dies and will not start. I've chk'ed the fuel filter and pressure tested the pump it was a little weak so I dropped the tank cleaned it out and replaced the fuel pump (Never Have Yet) blown out the lines chk'ed the fuel pressure and it is good. It getting spark ever time I turn it over. I only thing I can think of is timing chain and gear to be replaced? Do you agree?
I would really hate to retire the old girl she still holds 45 lbs oil pressure and doesn't drip or burn a drop of oil. I crawl under it every spring to change and grease everything for the summer in the mountains. She's been a faithful mountain climber and wilderness companion all these years. But age may be getting the best of her.
Back to top
View user's profile Send private message
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Mon Feb 07, 2005 11:31 pm    Post subject: Reply with quote

It might be a loose timing chain, but I doubt it since it would run very poorly if at all.

If it starts then dies, the usual suspects are the fuel pump ballast resistor, the ignition switch or the fuel pump relay. . Since yours dies under throttle, it's probably not the ignittion switch.

Try swapping out the relay first...could be a real quick fix.

If not, check for connections and continuity at the ballast resistor, which is usually on the driver's side inner fender. The 87 & 95 4.0's don't have them, but it seems to have been present in most years in between. It can be bypassed too, which is a really quick way to test if it's the problem.

HTH

Steve
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
jeep1947
Member


Joined: 08 Feb 2005
Location: Michigan

PostPosted: Wed Feb 09, 2005 6:24 pm    Post subject: Reply with quote

As a mechanic I have seen this problem before. It could be many things, however by what you have done to it already the next thing I would try is the MAP (Manifold absolute pressure) sensor. It detects engine load and if it is bad it can kill the motor when you put it in gear or step on the gas. It is located near the firewall and has two vaccum lines and one multiple wire plug running to it. The free and easy test is to unplug it with the vehicle off and then start the engine once unpluged. The engine will run mostly fine if this is the problem. If that is not the problem next step would be to shoot it with a timing gun and see if the timing chain did jump a couple of teeth. However it would most likely not run nice even at idle if this was the problem.
_________________
-1947 jeep willis
-1993 jeep cherokee
-1998 jeep wrangler
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group