Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Clicking/ticking from Cam Position Sensor, why?

Post new topic   Reply to topic     Forum Index -> TJ Forum
View previous topic :: View next topic  
Author Message

Joined: 16 Aug 2005

PostPosted: Tue Aug 16, 2005 4:45 pm    Post subject: Clicking/ticking from Cam Position Sensor, why? Reply with quote

I installed my M.O.R.E. MML and JKS Body lift the other day. All seemed to go well. The next day I start up the Jeep and go check on the engine for good measures. I pop the hood and hear a clicking noise coming from the passenger side of the motor. Its clicking/ticking about 5 times a second. I finally locate where its coming from and its the Cam Position Sensor. If I put my hand on it I can feel the clicking/ticking as well. Anyone know what’s wrong? I replaced the sensor with a new one today and it still does it. On the way home from work today the check engine light went on and the code was P0122 (Throttle Position Sensor Low Voltage), could this be the cause? The engine seems a bit louder since the clicking and just doesn’t sound right. The TPS code has been popping up randomly for the past year or two now, very sporadically. It popped up twice in the past 3 days though which is weird.

Thanks for any help

02 TJ, 4.0L, Manual, Sport
Back to top
View user's profile Send private message

Joined: 23 Jun 2005

PostPosted: Wed Aug 17, 2005 5:16 am    Post subject: Reply with quote

is it a mechanical tick for sure?
did you move wires around in the lift? is a wire getting slapped by a fan blade?
Back to top
View user's profile Send private message

Joined: 26 Aug 2005

PostPosted: Fri Aug 26, 2005 9:14 am    Post subject: ticking at cam sensor + P0122 Reply with quote

Hi guys. I have had EXACTLY the same experience with my 02 TJ
recently. And this is without any modifications. It started at about
65k miles with the loud-ish ticking near what I also found to be
the cam sensor. I second habers' opinion that it is mechanical
because putting my hand on the back of the sensor, it sure seems
like something is rapping on the sensor from the inside. I used
a tubing "stethoscope" to locate the sound to exactly the cam
sensor area.

I also have had the intermittent P0122 (TPS low volts) error.

The ticking was exceptionally loud for a while, then it only seemed
loud when the engine RPM was decreasing.. lately it has mostly
subsided, but I am still getting the P0122 code. None of this seems
to manifest itself in the form of poor engine performance (missing,
rough idle (well, not rougher than it usually is.... Wink ).

I checked the TPS connector for signs of corrosion/gunk and found it
clean and apparently mechanically sound. I have not yet removed the
sensor and ohmed it out for dead spots, etc.

Seems weird that these two symptoms are somehow related (coincidental?) for both of us.

There is only one event that I can say happened to me at about the time
the ticking started.. not sure if it's important at all.. I did screw up a
downshift and put it in 2nd instead of 4th, resulting in an uncomfortably
high (but very brief) engine RPM. I have since changed the oil and found
nothing unusual in it, and, again, no other symptoms, and the sound has
pretty much gradually gone away. Not sure if the events are related at all, but
wonder if habers has a similar event to correlate with the onset of
the noise?

And yes, it ticked even in neutral at idle when not moving.

Hope this adds some info..

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> TJ Forum All times are GMT - 8 Hours
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Visit for write-ups, forums and clubs

Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC. is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group