Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Transmision Problem


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
globalroute
Member


Joined: 27 Aug 2005

PostPosted: Sat Aug 27, 2005 11:41 am    Post subject: Transmision Problem Reply with quote

I just bought my first Jeep, a 1995 Grand Charokee straight six full time 4wd with 130000 miles. It's nice except when I come to a stop rapidly the engine lugs to the point that it almost dies. I had a similar problem with a 1993 chevy cavalier with a torque converter clutch solenoid problem. Does anyone have a good guess what this problem might be?
Back to top
View user's profile Send private message
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Sat Aug 27, 2005 11:51 am    Post subject: Reply with quote

Might possibly be the TPS??? Do you have any idle issues.. IE idleing up and down at stop signs???
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
globalroute
Member


Joined: 27 Aug 2005

PostPosted: Sat Aug 27, 2005 11:59 am    Post subject: Reply with quote

No, there are no idle problems once I'm stopped.
Back to top
View user's profile Send private message
globalroute
Member


Joined: 27 Aug 2005

PostPosted: Sat Aug 27, 2005 12:05 pm    Post subject: Reply with quote

also, a couple of times it has died when changing from reverse to drive and then accelerating
Back to top
View user's profile Send private message
cj3a
Member


Joined: 30 Aug 2005

PostPosted: Wed Aug 31, 2005 7:46 am    Post subject: Reply with quote

my jeep ran fine, but would not shift to save my life, it was the tps, I would at least test it.
Back to top
View user's profile Send private message
1fox2go
Member


Joined: 01 Dec 2004
Location: Fishersville, Virginia

PostPosted: Wed Aug 31, 2005 7:51 am    Post subject: Reply with quote

i changed my crank sensor

mine would die when i came to a stop at lites and signs and somtimes when i would shift in reverse and back up when i stopd to shift to drive it would die crank sensor fixed my problem
_________________
96 Cherokee 7.5 inch TnT long arm Locked F/R, D44 rear, 4.56s, 35x12.50 Muds/36x12.50 TSLs
Back to top
View user's profile Send private message Send e-mail AIM Address
globalroute
Member


Joined: 27 Aug 2005

PostPosted: Wed Aug 31, 2005 4:07 pm    Post subject: Reply with quote

I'll check the crank sensor and tps. there is a engine oil leak coming from somewhere...havent figured it out yet. Is this common with these engines?
Back to top
View user's profile Send private message
Code3TJ
Hacker
Hacker


Joined: 01 Jan 2004
Location: Uzbekistan

PostPosted: Thu Sep 01, 2005 12:35 am    Post subject: Reply with quote

Is it coming from the rear mounting surface of the oil pan? If so, it's likely the rear main seal.
_________________
Nothing to see here.
Back to top
View user's profile Send private message
1fox2go
Member


Joined: 01 Dec 2004
Location: Fishersville, Virginia

PostPosted: Thu Sep 01, 2005 4:38 am    Post subject: Reply with quote

does it just drip every now and then? Mine does that my dodge shadow did that my fathers ram does that my step mothers neon does that...i was told its just common with mopar
_________________
96 Cherokee 7.5 inch TnT long arm Locked F/R, D44 rear, 4.56s, 35x12.50 Muds/36x12.50 TSLs
Back to top
View user's profile Send private message Send e-mail AIM Address
S
Member


Joined: 08 Sep 2005

PostPosted: Thu Sep 08, 2005 1:53 pm    Post subject: Re: Transmision Problem Reply with quote

globalroute wrote:
I just bought my first Jeep, a 1995 Grand Charokee straight six full time 4wd with 130000 miles. It's nice except when I come to a stop rapidly the engine lugs to the point that it almost dies. I had a similar problem with a 1993 chevy cavalier with a torque converter clutch solenoid problem. Does anyone have a good guess what this problem might be?



I had a similar problem on my 95 GC. I have a 5.2 v8 on mine but I think this problem happen quite frequently on most modern fuel injected cars. On mine in the back of the throttle body fuel injectors there is a IAC valve thats needs to be removed and cleaned (or replace). You also have to clean out the bore hole on the throttle body where the IAC valve came out of. There is a lot of crud built up in that hole and that keeps the IAC valve from working propperly. I am the original owner of my GC and it only has 58k mile on it and this problem still occurs. I guess not only miles but time seems to have a big factor. Just for you info my 91 nissan 240sx has the same problem which was corrected cleaning the throttle body. Hope this helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group