Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Engine Dying / Erratic Idle

Post new topic   Reply to topic     Forum Index -> TJ Forum
View previous topic :: View next topic  
Author Message

Joined: 02 Oct 2005

PostPosted: Sun Oct 02, 2005 8:09 am    Post subject: Engine Dying / Erratic Idle Reply with quote


I am at a complete loss. I have a 99 TJ 4.0. My engine has been acting up. After driving for a short while, then getting on interstate, it started acting like it was running out of gas then would just completely die. When attempting to restart, the idle would be erratic if I could get it to turnover at all. Also if it rested for a while, I could get it to start again. So I replaced the entire fuel pump assembly, crankshaft position sensor, cap, rotor, air filter, and checked the plugs, wires, and coil.

Now I fire it up yesterday after I get the new fuel pump assembly in and drive it for about ten minutes, park and idle, and it dies.

Tow it back home. She fires right up. So I let it run in the driveway. I rev it up and its fine. She idles for about 30 -35 minutes and sputters out. Mess around with it. Actually take a spark plug out and try to fire it up without the plug, it starts. Makes a noise like it pushes something out. Shut it off quickly. Put the plug back in and it fires right back up. Eventually dies, do the plug thing, works again. Repeat 4 times.

So I feel like there is some pressure built up after it gets warm. Every time this happens it happens after the engine has been running for a while. Could this be my cat converter? Vacuum leak? Please help. Sorry for the long explanation.
Back to top
View user's profile Send private message

Joined: 07 Jan 2004
Location: Hanover, MD

PostPosted: Sun Oct 02, 2005 11:56 am    Post subject: Reply with quote

Try looking at the cat/exhaust manifold after it runs for a decent duration, if it's glowing cherry red, you have some type of blockage, probably time for a new cat...

Just a thought...

Something else I thought about, put a fuel psi gauge on the schrader valve and see what is going on there when the motor said that you replaced the entire pump assembly so I doubt that's the problem, but it's definitely something I would double check.

2002 TJ Wrangler X
Patriot Blue 4.0L
Check Website for Mods/Photos

Amsoil Dealer
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> TJ Forum All times are GMT - 8 Hours
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Visit for write-ups, forums and clubs

Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC. is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group