Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Error - NO BUS


 
Post new topic   Reply to topic     Forum Index -> TJ Forum
View previous topic :: View next topic  
Author Message
Ra
Member


Joined: 12 Oct 2005

PostPosted: Wed Oct 12, 2005 1:51 pm    Post subject: Error - NO BUS Reply with quote

Could errors like this: (travelling at about 80kms, notice the NO BUS error and orange engine light error. Speedo and tacho dead) Sorry about the pic size.



be caused by this?:


Whats the best way to clean this battery terminal?

Cheers,
Back to top
View user's profile Send private message
ehirner
Moderator
Moderator


Joined: 01 Jan 2004
Location: Eastern PA

PostPosted: Wed Oct 12, 2005 2:34 pm    Post subject: Reply with quote

Get a battery terminal brush and some of the spray that's used to prevent the corrosion from occuring. Check out any local auto parts store.
_________________
04 Unlimited
Back to top
View user's profile Send private message AIM Address
KnightFire
Member


Joined: 07 Jan 2004
Location: Hanover, MD

PostPosted: Thu Oct 13, 2005 12:58 am    Post subject: Reply with quote

Put some dielectic grease on those terminals after cleaning.


KnightFire
_________________
2002 TJ Wrangler X
Patriot Blue 4.0L
Check Website for Mods/Photos

Amsoil Dealer
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
Black2001TJ
Leopard Skin
Leopard Skin


Joined: 03 Jan 2004

PostPosted: Thu Oct 13, 2005 5:12 am    Post subject: Reply with quote

As for the No Bus part, what year is your Jeep? I doubt it's related to the battery terminal, but yes, you need to clean that!

Try pushing on the center of your display where it says No Bus to see if you can get the connector to seat. It's most likely a loose connection from what I remember, but I could be wrong. Good luck, keep us posted.
_________________
Just damn happy to have my Jeep back, it's been a long time!
Back to top
View user's profile Send private message Send e-mail
Docjim
Member


Joined: 04 Apr 2005

PostPosted: Mon Nov 07, 2005 10:10 am    Post subject: Reply with quote

My Jeep did the same thing a few weeks ago. It would come and go. My mechanic pulled the console and couldn't find anything, but when he put it back it stopped the problem. He figured it was a loose connection and he tightened everything he could. The problem has not returned.
Back to top
View user's profile Send private message
KnightFire
Member


Joined: 07 Jan 2004
Location: Hanover, MD

PostPosted: Mon Nov 07, 2005 6:15 pm    Post subject: Reply with quote

Docjim wrote:
My Jeep did the same thing a few weeks ago. It would come and go. My mechanic pulled the console and couldn't find anything, but when he put it back it stopped the problem. He figured it was a loose connection and he tightened everything he could. The problem has not returned.


Yep, pretty typical problem on the Jeeps and Neons, dunno why, just is. A good fix is to do just as described above, pull the cluster, clean the terminals and connectors, slightly pry them up a bit so they make good contact when you re-insert the cluster.

KnightFire
_________________
2002 TJ Wrangler X
Patriot Blue 4.0L
Check Website for Mods/Photos

Amsoil Dealer
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> TJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group