Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Is this Normal and more...


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
DIGITRUCK
Member


Joined: 11 Dec 2005

PostPosted: Tue Dec 13, 2005 2:00 pm    Post subject: Is this Normal and more... Reply with quote

Hey,


88 XJ Cherokee Laredo 4.0L Auto. Just got done converting cooling system from closed to open. Now has CSF 3-Row All Metal Rad. Way Better than Stock.

With the engine idling and warmed-up, if I switch on to the MAX HEAT settings and blower on Full I notice the Volt Meter will drop from almost 14V to a little less than 12V. Only way to bring it back up to almost 14V is to rev the engine or start driving it.

It does the same thing when I switch on the A/C to MAX too.

It did this with the old Alternator so I replaced it with a 170A one but the Volt Meter still seems to be doing the same thing.

1. Is this Normal?

2. I'm not sure on which hose to install the "T" that comes with the Prestone Flush/Fill Kit. Standing directly in front of the motor and looking at the motor from the front you see two narrow hoses on each side of the top radiator hose on the thermostat housing. Is it the narrow hose on the furthest right (my right) or left?

3. At night when I switch on my dashlights, the GREEN RIGHT TURN SIGNAL is lit but not blinking. It will blink when I activate it. The left one is not lit but will come on lit and blink when I activate it and unlit when deactivated. What's causing this GREEN RIGHT TURN SIGNAL to be lit and how can I make it stay off like the left one?

4. My door locks (4 door) are wired into my aftermarket alarm so that when armed the doors lock. However, not all of them lock. The right and left rear pass doors stay unlocked. They are also difficult to lock manually from the inside by pressing the lever switch on each door. Do you think I have to open each door panel and lube them?


Thx, Phil


Last edited by DIGITRUCK on Tue Dec 13, 2005 3:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
scorpio_vette
Member


Joined: 02 Nov 2005
Location: milwaukee WI

PostPosted: Tue Dec 13, 2005 2:14 pm    Post subject: Reply with quote

try hitting and kicking the dash. that's how i fix 90% of my electrical issues.
________
weed vaporizer


Last edited by scorpio_vette on Wed Feb 02, 2011 4:59 pm; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger MSN Messenger
ILLXJ
Member


Joined: 08 Aug 2005
Location: S. ILL.

PostPosted: Tue Dec 13, 2005 6:43 pm    Post subject: Reply with quote

The volt meter on my 96 does the same thing. I believe it is an issue with the grounds for the instrument panel. JIM.
________
Kent engine
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group