Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Oil gauge


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
Shimma
Member


Joined: 23 Mar 2006
Location: Wellington, New Zealand

PostPosted: Wed Apr 05, 2006 11:31 pm    Post subject: Oil gauge Reply with quote

My '96 Cherokee Sport oil gauge dosen't work,well it moves rapidly from left,to right off the gauge,lying horizontal,after the ignition is switched on!!?? It has been like it,since I bought it last week,the engine sounds fine,no abnormal noises,idles nicely,drives great,dipstick reading ok, so.... any ideas,please? cheers in advance...Jim
Back to top
View user's profile Send private message
97XJ Jeeper
Member


Joined: 23 Mar 2006
Location: Southeast Iowa

PostPosted: Thu Apr 06, 2006 1:04 am    Post subject: Reply with quote

have you checked to see if the wire has unplugged from the sending unit. that would be the first thing i would check.
two cents
_________________
JUST PUT IT IN 4X4 AND GO FOR IT!!!
Magnaflow high flow cat
FLOWMASTER SUPER 40
2 1/2" pipe cat back
Videos my XJ
http://youtube.com/profile?user=JeepXJJeeper
Back to top
View user's profile Send private message Send e-mail
scorpio_vette
Member


Joined: 02 Nov 2005
Location: milwaukee WI

PostPosted: Thu Apr 06, 2006 7:30 am    Post subject: Reply with quote

i agree. check the plug and the little connectors inside. mine were worn out, so i used a pick and gently bent the little connectors so they would fit a little tighter and also replaced the oil pressure sender and that fixed it.
________
indica strains


Last edited by scorpio_vette on Wed Feb 02, 2011 5:06 pm; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger MSN Messenger
Shimma
Member


Joined: 23 Mar 2006
Location: Wellington, New Zealand

PostPosted: Thu Apr 06, 2006 8:02 am    Post subject: Reply with quote

Thanks guys,will check that out, appreciated,and I've just found the page in my Haynes manual with a picture of the unit...cheers...Jim
Back to top
View user's profile Send private message
Shimma
Member


Joined: 23 Mar 2006
Location: Wellington, New Zealand

PostPosted: Fri Apr 21, 2006 12:59 am    Post subject: Reply with quote

Yes it was the sender unit,but not the one as fitted originally!Someone had put a wrong sender in,only had the wires for the panel light?,not the original combined oil pressure/panel light,two sets of wires?well something like that,I can't remember exactly what my mechanic exactly said now,but the engine still had normal oil pressure, when he checked it with his garage tester gear.
So a new proper one is on its way......Update: now working fine!!Cheers... Jim
_________________
1996 Black Cherokee Sport 4.0
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group