Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Grinding noise in Park and Neutral


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
jhopwood
Member


Joined: 26 Apr 2006

PostPosted: Wed Apr 26, 2006 1:50 pm    Post subject: Grinding noise in Park and Neutral Reply with quote

1st time Jeep owner, bought a 95 Cherokee 4.0 Automatic, it has been running perfectly, but today a loud grinding noise started coming from the Transmission (I think)when it is in Park or Neutral, but as soon as I put it in gear the grinding noise quits.
Someone said my transmission linkage could be out of adjustment or I could have loose Flywheel bolts, but it only occurs in Park and Neutral.
Any help or Ideas?
Thanks
Back to top
View user's profile Send private message Send e-mail
solt
Member


Joined: 23 Mar 2006
Location: Poland

PostPosted: Wed Apr 26, 2006 2:16 pm    Post subject: Reply with quote

I could be also a short circuit in starter area. Starter is cut off if not in either P od N. I got a problem with starter relay while it is raining and got same effect Smile
_________________
XJ'95 +2"
Back to top
View user's profile Send private message
jhopwood
Member


Joined: 26 Apr 2006

PostPosted: Wed Apr 26, 2006 2:27 pm    Post subject: Reply with quote

Ok I will look into the starter, it does almost sound like the starter is engaging, so that may be another option to look into.
thanks
Back to top
View user's profile Send private message Send e-mail
jhopwood
Member


Joined: 26 Apr 2006

PostPosted: Sun May 07, 2006 7:19 pm    Post subject: Problem fixed Reply with quote

Well if anyone ever has this problem it seems to have been a ignition gone bad. I guess the circuits had gotten bad and it just kept causing my starter to stick on in park and neutral. I took apart the steering column, took the old key ignition out and put the new one in 29.99 from Advanced Auto Parts. That was a week ago and I have not had a problem since.
Thanks for the help.
Very Happy
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group