Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

1995 grand cherokee runs horribly Please Help


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
rshvllerocket20
Member


Joined: 03 Jun 2006

PostPosted: Sat Sep 02, 2006 6:00 pm    Post subject: 1995 grand cherokee runs horribly Please Help Reply with quote

I have a 1995 grand cherokee limited 4x4xwith the 5.2l engine. Most of the time it runs great however sometimes it runs like it wants to die. The idle will surge and when you try to go it will hold back then all of a sudden like a nuetral drop it will take off the cut out at random. In attempts to fix this I have replace the following cap, rotor, plugs, wires, egr valve and transducer, tps, map sensor, Idle air control valve, coil, temp sensor, air temp sensor, fuel pump and oxygen sensor. The ironic thing is sometimes when it acts up or even runs normal the check engine light will come on. I then check the code and it always comes up a 21 which is for the oxygen sensor system. I have had it at the shop and they found nothing however replaced a o2 sensor. Guys I really need help the truck looks good and I love it but this problem is killing me.
Back to top
View user's profile Send private message
nixt
Member


Joined: 17 Aug 2005
Location: Atlanta/Athens, Georgia

PostPosted: Sat Sep 02, 2006 6:08 pm    Post subject: Reply with quote

I had a similar problem with my '98 ZJ 5.9- Heres the post I made and the thread that followed:

http://www.jeephorizons.com/phpbb/viewtopic.php?t=6442&highlight=

-nixt
_________________
1998 ZJ 5.9 Limited W/242 swap
JKS disconnects & Garmin GPS
Heavy duty OME Suspension kit
with 2" coil spacers for 3.5-3.75 total lift
235/85R16 Goodyear MTR's Measure a true 32"

Life has No Value,
But Death Has Its Price.
Back to top
View user's profile Send private message
rshvllerocket20
Member


Joined: 03 Jun 2006

PostPosted: Sat Sep 02, 2006 6:17 pm    Post subject: Reply with quote

yes I replace the coil but when it is acting up if I mash the gas to the floor it will take off like a bat out of hell. It acts up from the idle to 50 miles per hour. I have had the injectors professionally cleaned and tried everything but the right thing to fix this problem. I did also put on a new muffler and tail pipe as they were bad and it appears someone had the cat replaced before me.
Back to top
View user's profile Send private message
nixt
Member


Joined: 17 Aug 2005
Location: Atlanta/Athens, Georgia

PostPosted: Sat Sep 02, 2006 8:52 pm    Post subject: Reply with quote

(all of this post depends on if you have to get your emissions testing in the area where you have the Jeep registered) As for your cat, the last time you had it emissions tested, did it barely pass or did it pass with flying colors? The only reason I ask is because you say it isn't the stock catalytic converter and who knows what the guy before you did to it. The Cat really doesn't work well if you've gotten all kinds of water, mud, and river(stream) gunk inside of it.
-nixt
_________________
1998 ZJ 5.9 Limited W/242 swap
JKS disconnects & Garmin GPS
Heavy duty OME Suspension kit
with 2" coil spacers for 3.5-3.75 total lift
235/85R16 Goodyear MTR's Measure a true 32"

Life has No Value,
But Death Has Its Price.
Back to top
View user's profile Send private message
rshvllerocket20
Member


Joined: 03 Jun 2006

PostPosted: Tue Sep 05, 2006 1:01 pm    Post subject: Reply with quote

had the cat checked today and said it was all good nothing wrong with it. I am at a loss with it.
Back to top
View user's profile Send private message
Jeep Iceland
Member


Joined: 12 Nov 2004
Location: Iceland

PostPosted: Tue Sep 05, 2006 6:35 pm    Post subject: Reply with quote

I'd check the wiring/plugs carefully to and from the oxygen sensor and also use contact cleaner on the sensor plug.
_________________
F.D
1996 Limited 5.2
http://www.cardomain.com/id/461ponchos96jeep
1976 Trans Am
http://www.cardomain.com/memberpage/531601
Back to top
View user's profile Send private message Visit poster's website
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Thu Sep 07, 2006 8:29 pm    Post subject: Reply with quote

5.2's get very hot.. Have you checked to see if you have melted any spark plug wires.. I have had it happen to me on several occasions.. I carry a complete set of spare wires in my tool box..
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
rshvllerocket20
Member


Joined: 03 Jun 2006

PostPosted: Thu Sep 07, 2006 11:49 pm    Post subject: Reply with quote

yes I checked the wires again this weekend pulled the plugs cleaned them reset the gap. this thing drives me crazy I ordered a set of injectors as I thought maybe one of them was hanging open.
Back to top
View user's profile Send private message
RussellRowell
Member


Joined: 09 Feb 2006
Location: Jacksonville Florida

PostPosted: Sat Sep 09, 2006 2:21 pm    Post subject: Reply with quote

Get a vaccum gauge and test all your vaccum lines..... I had the same problem a while back. It occured when I changed my plugs and wires. I broke a vaccum line ( if your looking @ the engine ) on the left side, on top of the valve cover, towards the front under the wire loom. Because of this break, it was making the computer reajust making it run lean in which it gave me a 21 fault code. I tested my O2 sensor and it was fine. But I finally found the break by taking a small hose and using it like a stethoscope. After the fix, it took a while for everything to run normal again. GL
_________________
1994 w327k
Cold Air K&N / Taurus Elec Fan / O Yellow Top
Dino Max Turbo / Hi Flo Cat / Poly Bush Kit
NP249 / 5.2 / MB Motoring Rims/ 1500 watts
Back to top
View user's profile Send private message Send e-mail
rshvllerocket20
Member


Joined: 03 Jun 2006

PostPosted: Thu Sep 14, 2006 1:23 pm    Post subject: Reply with quote

I have checked all of the vacuum lines and none have a leak. In fact after sitting this weekend I still had vacuum in the lines. Today I now have a check engine light of 23. I have already replaced the air intake temp sensor. Let me know if anyone has any ideas and at least now I am getting a different code than the 21. Maybe this helps but I replaced 4 of the injectors with rebuilt ones. I have to do the other 4 this weekend.
Back to top
View user's profile Send private message
rshvllerocket20
Member


Joined: 03 Jun 2006

PostPosted: Sat Sep 23, 2006 3:41 am    Post subject: Reply with quote

I found the answer it was the fuel injectors. I replaced them because I got all 8 rebuilt for 120.00 on ebay. I removed passengar side with ease and found drivers side to be missing 2 of the injector o rings. I dont know how they didnt leak but know it takes off and idles great. I also found the aspirator tube cracked this is probably causing the 21 code.
Back to top
View user's profile Send private message
RussellRowell
Member


Joined: 09 Feb 2006
Location: Jacksonville Florida

PostPosted: Wed Oct 04, 2006 11:52 am    Post subject: Reply with quote

where is the aspirator tube so I can check mine? Couldn't find it in my book.
Thanks
Back to top
View user's profile Send private message Send e-mail
rshvllerocket20
Member


Joined: 03 Jun 2006

PostPosted: Wed Oct 04, 2006 11:59 am    Post subject: Reply with quote

It is the air tube that comes off egr valve and runs down to back of exhaust manifold on passenger tube. It is really hard to see in fact I could barely see it myself but it looks like it went into manifold. what problem are you having with your GC. Thanks Mike
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group