Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Power loss during acceleration


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
Bson
Member


Joined: 22 Oct 2006
Location: Sydney

PostPosted: Sun Oct 22, 2006 1:24 am    Post subject: Power loss during acceleration Reply with quote

Hi! Recently bought a 97 Cherokee, it's been working fine since we bought it and other than a main seal change at the "oil service" last week there has been no issues...

While driving today (two weeks after the service and the seal change) I noticed that during acceleration from very low speads the engine power drops, like if I was taking the foot off the gas pedal...

It happened a few times today and the engine was warm every time. It never hapens above 20 km/h, only when I accelerate from low speeds.

I've searched around without finding many clues... I'm guessing fuel pump or fuel hose leak, but can not see anything strange under the hood.

Can some one help out?
/Bson
Back to top
View user's profile Send private message
Code3TJ
Hacker
Hacker


Joined: 01 Jan 2004
Location: Uzbekistan

PostPosted: Sun Oct 22, 2006 11:11 am    Post subject: Reply with quote

Has it recently been tuned up? Have you checked for engine codes? If all of that's fine, my guess would be your crank position sensor.
_________________
Nothing to see here.
Back to top
View user's profile Send private message
adamzski
Member


Joined: 29 Oct 2007
Location: massachusetts

PostPosted: Mon Oct 29, 2007 7:55 pm    Post subject: Re: power loss during acceleration Reply with quote

I had the same problem, my cherokee XJ has a manual transmission, and at first i thought the clutch was slipping, so dont rule that out if it applies to you. after ruling that out, i replaces the tps, map, and iac. the sensor that made the most difference for me was the tps, if you do alot of highway driving, our tps can get worn at one spot, and when you hit that during acceleration, it will send an incorrect reading to your computer causing it to buck and loose some power at that point, so i would try that.
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group